summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2017-06-02 12:48:57 +0200
committerSebastian Dröge <sebastian@centricular.com>2017-06-16 13:44:49 +0300
commitf79b21f12ca953c7d10f8573e4edc8b2dfc1dd14 (patch)
treec39b66359e6a638938c48cfebbff2634f36f38f0 /meson.build
parent463929af3e29ae4ae024a63a9004e3693324476b (diff)
downloadgst-omx-f79b21f12ca953c7d10f8573e4edc8b2dfc1dd14.tar.gz
meson: define HAVE_VIDEO_EXT if OMX_VideoExt.h is present
Meson build wasn't defining the HAVE_VIDEO_EXT like configure.ac does. https://bugzilla.gnome.org/show_bug.cgi?id=783346
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7ce4c4a..d99d275 100644
--- a/meson.build
+++ b/meson.build
@@ -168,6 +168,9 @@ have_external_omx = cc.has_header(
args : gst_omx_args,
required : false)
extra_video_headers = ''
+# Our internal OpenMAX IL headers have OMX_VideoExt.h
+have_video_ext = true
+
if have_external_omx
have_video_ext = cc.has_header (
'OMX_VideoExt.h',
@@ -179,6 +182,10 @@ if have_external_omx
endif
endif
+if have_video_ext
+ cdata.set ('HAVE_VIDEO_EXT', 1)
+endif
+
have_omx_vp8 = cc.has_header_symbol(
'OMX_Video.h',
'OMX_VIDEO_CodingVP8',