summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2017-10-17 12:11:04 +0200
committerSebastian Dröge <sebastian@centricular.com>2017-10-19 16:20:39 +0200
commita0e7fc79e3ddfb79cc2fe6cca01e4006560ff90a (patch)
treedd5023cad3e9d31130992cac9d9a4ef0ea1eafa6 /meson.build
parent62b96b6e14d41abe9c3fd809999d033962645651 (diff)
downloadgst-omx-a0e7fc79e3ddfb79cc2fe6cca01e4006560ff90a.tar.gz
check if Allegro headers are present when building zynqultrascaleplus
The Zynq UltraScale+ uses a custom version of OMX implementing several 3rd party extensions. Make sure those are present when building this target. https://bugzilla.gnome.org/show_bug.cgi?id=788064
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5c6425b..6656dbc 100644
--- a/meson.build
+++ b/meson.build
@@ -267,6 +267,13 @@ elif omx_target == 'bellagio'
cdata.set('USE_OMX_TARGET_BELLAGIO', 1)
elif omx_target == 'zynqultrascaleplus'
cdata.set('USE_OMX_TARGET_ZYNQ_USCALE_PLUS', 1)
+ have_allegro_header = cc.has_header (
+ 'OMX_Allegro.h',
+ args : gst_omx_args,
+ required : false)
+ if not have_allegro_header
+ error ('Need Allegro OMX headers to build for Zynq UltraScale+. Use with_omx_header_path option to specify the path of those headers.')
+ endif
elif omx_target == 'tizonia'
cdata.set('USE_OMX_TARGET_TIZONIA', 1)
tizil_dep = dependency('tizilheaders', version : tizil_req)