summaryrefslogtreecommitdiff
path: root/omx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'omx/Makefile.am')
-rw-r--r--omx/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/omx/Makefile.am b/omx/Makefile.am
index da650c8..adbc9ab 100644
--- a/omx/Makefile.am
+++ b/omx/Makefile.am
@@ -1,5 +1,10 @@
plugin_LTLIBRARIES = libgstomx.la
+if HAVE_VP8
+VP8_C_FILES=gstomxvp8dec.c
+VP8_H_FILES=gstomxvp8dec.h
+endif
+
libgstomx_la_SOURCES = \
gstomx.c \
gstomxvideodec.c \
@@ -9,6 +14,7 @@ libgstomx_la_SOURCES = \
gstomxmpeg2dec.c \
gstomxh264dec.c \
gstomxh263dec.c \
+ $(VP8_C_FILES) \
gstomxwmvdec.c \
gstomxmpeg4videoenc.c \
gstomxh264enc.c \
@@ -24,6 +30,7 @@ noinst_HEADERS = \
gstomxmpeg4videodec.h \
gstomxh264dec.h \
gstomxh263dec.h \
+ $(VP8_H_FILES) \
gstomxwmvdec.h \
gstomxmpeg4videoenc.h \
gstomxh264enc.h \