summaryrefslogtreecommitdiff
path: root/omx/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'omx/meson.build')
-rw-r--r--omx/meson.build57
1 files changed, 57 insertions, 0 deletions
diff --git a/omx/meson.build b/omx/meson.build
new file mode 100644
index 0000000..08447e6
--- /dev/null
+++ b/omx/meson.build
@@ -0,0 +1,57 @@
+omx_sources = [
+ 'gstomx.c',
+ 'gstomxbufferpool.c',
+ 'gstomxvideo.c',
+ 'gstomxvideodec.c',
+ 'gstomxvideoenc.c',
+ 'gstomxaudiodec.c',
+ 'gstomxaudioenc.c',
+ 'gstomxmjpegdec.c',
+ 'gstomxmpeg4videodec.c',
+ 'gstomxmpeg2videodec.c',
+ 'gstomxh264dec.c',
+ 'gstomxh263dec.c',
+ 'gstomxwmvdec.c',
+ 'gstomxmpeg4videoenc.c',
+ 'gstomxh264enc.c',
+ 'gstomxh263enc.c',
+ 'gstomxaacdec.c',
+ 'gstomxmp3dec.c',
+ 'gstomxaacenc.c',
+ 'gstomxamrdec.c',
+ 'gstomxaudiosink.c',
+ 'gstomxanalogaudiosink.c',
+ 'gstomxhdmiaudiosink.c',
+]
+
+extra_inc = []
+extra_c_args = []
+
+if have_omx_vp8
+ omx_sources += 'gstomxvp8dec.c'
+endif
+
+if have_omx_theora
+ omx_sources += 'gstomxtheoradec.c'
+endif
+
+if not have_external_omx
+ extra_inc += include_directories ('openmax')
+endif
+
+optional_deps = []
+if gstgl_dep.found()
+ optional_deps += gstgl_dep
+ extra_c_args += ['-DGST_USE_UNSTABLE_API']
+endif
+
+gstomx = library('gstomx',
+ omx_sources,
+ c_args : gst_omx_args + extra_c_args,
+# link_args : noseh_link_args,
+ include_directories : [configinc] + extra_inc,
+ dependencies : [gstvideo_dep, gstaudio_dep, gstbase_dep, gstcontroller_dep,
+ libm] + optional_deps,
+ install : true,
+ install_dir : plugins_install_dir,
+)