summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-11-26 16:32:01 +0000
committerTim-Philipp Müller <tim@centricular.com>2017-11-26 16:32:01 +0000
commitb890daf7b595c5fee6739d04d9057b08812aa84a (patch)
tree034b1928ef993d6bd5204fa33632c283f828d6b9 /Makefile.am
parent26b13f16d63aa0524407362a6caf7a40f8f08e98 (diff)
downloadgstreamer-plugins-bad-b890daf7b595c5fee6739d04d9057b08812aa84a.tar.gz
win32: remove .def file with exports
They're no longer needed, symbol exporting is now explicit via GST_EXPORT in all cases (autotools, meson, incl. MSVC).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index d098b3dff..8ef39bd51 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,13 +8,10 @@ DIST_SUBDIRS = \
gst gst-libs sys ext pkgconfig \
m4 common docs tests po tools
-# include before EXTRA_DIST for win32 assignment
-include $(top_srcdir)/common/win32.mak
-
EXTRA_DIST = \
depcomp \
AUTHORS COPYING NEWS README RELEASE REQUIREMENTS \
- ChangeLog gst-plugins-bad.doap autogen.sh $(win32) \
+ ChangeLog gst-plugins-bad.doap autogen.sh \
$(shell find "$(top_srcdir)" -type f -name meson.build ! -path "$(top_srcdir)/$(PACKAGE_TARNAME)-*" ) \
meson_options.txt \
gst-libs/gst/interfaces/build_mkenum.py \
@@ -51,7 +48,6 @@ check: check-exports
# cruft: plugins that have been merged or moved or renamed
CRUFT_FILES = \
- $(top_builddir)/win32/common/config.h-new \
$(top_builddir)/gst-plugins-bad.spec \
$(top_builddir)/common/shave \
$(top_builddir)/common/shave-libtool \
@@ -147,7 +143,8 @@ CRUFT_DIRS = \
$(top_srcdir)/ext/tarkin \
$(top_srcdir)/ext/theora \
$(top_srcdir)/ext/vp8 \
- $(top_srcdir)/sys/mfc
+ $(top_srcdir)/sys/mfc \
+ $(top_srcdir)/win32
include $(top_srcdir)/common/cruft.mak