summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2013-09-02 13:40:37 +0100
committerTim-Philipp Müller <tim@centricular.net>2013-09-02 13:40:37 +0100
commit994739332d229a96fdc6bee9932d72349c29c614 (patch)
treeaa0610b43ff334b4602b5ba3a684817b7ca506fa /Makefile.am
parentadc17aa87999908bc078d1a52e0f508c2884f867 (diff)
downloadgstreamer-plugins-bad-994739332d229a96fdc6bee9932d72349c29c614.tar.gz
Change how win32/common/config.h is updated
Generate win32/common/config.h-new directly from config.h.in, using shell variables in configure and some hard-coded information. Change top-level makefile so that 'make win32-update' copies the generated file to win32/common/config.h, which we keep in source control. It's kept in source control so that the git tree is buildable from VS. This change is similar to the one recently applied to GStreamer and gst-plugins-good. The previous config.h file in -bad was in pretty bad shape, so unlike core and base, I didn't attempt to leave it strictly the same, but fixed it as necessary. Needs testing I cannot do myself. https://bugzilla.gnome.org/show_bug.cgi?id=569015
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e25a3958..6188f583a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,10 @@ check-torture:
true
endif
+win32-update:
+ cp $(top_builddir)/win32/common/config.h-new \
+ $(top_srcdir)/win32/common/config.h
+
include $(top_srcdir)/common/coverage/lcov.mak
check: check-exports