summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2010-01-13 00:38:47 +0000
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2010-01-13 00:42:21 +0000
commite15d4c44aa7880d9d8e6b55808cec0d8d9114c4a (patch)
tree187c3d8bbe32430473d8964f1f7fdc0e28986372 /Makefile.am
parent4be0225870ffcf290cf5109f96a01977dba2c6e6 (diff)
downloadgstreamer-plugins-bad-e15d4c44aa7880d9d8e6b55808cec0d8d9114c4a.tar.gz
build: include cruft.mak and add recently-merged plugins to cruft list
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index eb588f5f4..18593b09b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,3 +37,19 @@ endif
include $(top_srcdir)/common/coverage/lcov.mak
+
+# cruft: plugins that have been merged or moved or renamed
+
+CRUFT_FILES = \
+ $(top_builddir)/gst/aacparse/.libs/*.{so,dll,DLL,dylib} \
+ $(top_builddir)/gst/amrparse/.libs/*.{so,dll,DLL,dylib} \
+ $(top_builddir)/gst/flacparse/.libs/*.{so,dll,DLL,dylib}
+
+CRUFT_DIRS = \
+ $(top_srcdir)/gst/aacparse \
+ $(top_srcdir)/gst/amrparse \
+ $(top_srcdir)/gst/flacparse
+
+include $(top_srcdir)/common/cruft.mak
+
+all-local: check-cruft