summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2010-04-14 16:32:34 -0700
committerDavid Schleef <ds@schleef.org>2010-04-14 16:43:23 -0700
commitf6f9563dc80ad993a0535e1484c893509753966f (patch)
tree925d2980cf71d4c49ad51665a67e1d7d58ec4b4b /Makefile.am
parentc48de5c594a090432cb520596273fc620ea1120e (diff)
downloadgstreamer-plugins-bad-f6f9563dc80ad993a0535e1484c893509753966f.tar.gz
tools: Add element-maker
Add a script that creates elements based on any of the GStreamer base classes. It isn't very user friendly at the moment, one needs to edit the script to make it work properly. Each base class has a template file describing what to put into the constructed element. Eventually, these templates should be moved to reside with the base class source and installed to a well-known directory, where an installed script could find them. The template files use the .c ending so editors know they are C source, but gst-indent doesn't handle them correctly. So they need to be committed with -n. Ugh. I'll try to figure out a fix for that soon.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 47cade25c..454e77335 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,11 +2,11 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
SUBDIRS = \
gst-libs gst sys ext pkgconfig \
- m4 common docs tests po
+ m4 common docs tests po tools
DIST_SUBDIRS = \
gst gst-libs sys ext pkgconfig \
- m4 common docs tests po
+ m4 common docs tests po tools
# include before EXTRA_DIST for win32 assignment
include $(top_srcdir)/common/win32.mak