summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2005-11-06 22:16:27 +0000
committerJulien Moutte <julien@moutte.net>2005-11-06 22:16:27 +0000
commitd55ac2830b57502bcd6d6adfab2e48fd228fcdb1 (patch)
tree2b3113dca3ac63f09dcb58c1e04e80e6ee1adbe7 /Makefile.am
parent2438f5851e8c0d6e98cf45fc50300ca4387bc470 (diff)
downloadgstreamer-plugins-bad-d55ac2830b57502bcd6d6adfab2e48fd228fcdb1.tar.gz
Makefile.am: examples in dist subdirs.
Original commit message from CVS: 2005-11-06 Julien MOUTTE <julien@moutte.net> * Makefile.am: examples in dist subdirs. * configure.ac: enable parameter for building examples. * docs/plugins/gst-plugins-bad-plugins.args: * docs/plugins/inspect/plugin-dfbvideosink.xml: * examples/Makefile.am: Updates.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0eccbb0fa..6fa0496ef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,18 @@
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+if BUILD_EXAMPLES
+SUBDIRS_EXAMPLES = examples
+else
+SUBDIRS_EXAMPLES =
+endif
+
SUBDIRS = \
gst sys ext \
- m4 common docs
+ m4 common docs \
+ $(SUBDIRS_EXAMPLES)
+
+DIST_SUBDIRS = \
+ gst sys ext m4 common docs examples
EXTRA_DIST = \
gst-plugins-bad.spec depcomp \