summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Jägenstedt <philipj@opera.com>2010-05-20 16:49:03 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2010-05-21 08:26:59 +0200
commit1e5f37165071977c8338f7125c79846de5d47d6e (patch)
tree27c36357ec40ef19fbf2813100b7cd66f024a326 /configure.ac
parentd0f09279edc40690bb0a0cbfa45ed88df32010ec (diff)
downloadgstreamer-plugins-bad-1e5f37165071977c8338f7125c79846de5d47d6e.tar.gz
vp8: link with -lm -lpthread when testing for vp8 encoder/decoder
Fixup for bug #619172.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 92d8c735f..ae8d34c60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1487,6 +1487,9 @@ AG_GST_CHECK_FEATURE(VP8, [VP8 decoder], vp8, [
vpx/vpx_codec.h, [
HAVE_VP8_ENCODER=no
HAVE_VP8_DECODER=no
+
+ OLD_LIBS="$LIBS"
+ LIBS="$LIBS -lm -lpthread"
AC_CHECK_LIB(vpx, vpx_codec_vp8_cx_algo, [
HAVE_VP8=yes
AC_DEFINE(HAVE_VP8_ENCODER, 1, [Defined if the VP8 encoder is available])
@@ -1497,6 +1500,7 @@ AG_GST_CHECK_FEATURE(VP8, [VP8 decoder], vp8, [
AC_DEFINE(HAVE_VP8_DECODER, 1, [Defined if the VP8 decoder is available])
VPX_LIBS="-lvpx"
])
+ LIBS="$OLD_LIBS"
])
AC_SUBST(VPX_LIBS)
])