summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2010-11-05 00:32:35 +0000
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2010-11-05 00:32:35 +0000
commit2362acbec3b8fd674521e286ad857277e306aeb1 (patch)
treec791818376629c3e0f24bb4a9e2c0f319736b59e /configure.ac
parent1ab0aa6544994323e579555c9688b34d14cb5e69 (diff)
downloadgstreamer-plugins-bad-2362acbec3b8fd674521e286ad857277e306aeb1.tar.gz
configure: don't even check for Gtk+ if --disable-examples is specified
There are Gtk+-based examples in plugin dirs and tests/icles/ too, and we want to disable those as well then.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 45972c8b8..c057cd713 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,17 +206,19 @@ AC_SUBST(GSTPB_PREFIX)
dnl GTK is optional and used in examples
HAVE_GTK=NO
-AC_MSG_CHECKING([which gtk+ version to compile examples against (optional)])
-AC_ARG_WITH([gtk],
- AC_HELP_STRING([--with-gtk=3.0|2.0],
- [which gtk+ version to compile against (default: 2.0)]),
- [case "$with_gtk" in
- 2.0|3.0) ;;
- *) AC_MSG_ERROR([invalid gtk+ version specified]);;
- esac],
- [with_gtk=2.0])
-AC_MSG_RESULT([$with_gtk])
-PKG_CHECK_MODULES(GTK, gtk+-x11-$with_gtk, HAVE_GTK=yes, HAVE_GTK=no)
+if test "x$BUILD_EXAMPLES" = "xyes"; then
+ AC_MSG_CHECKING([which gtk+ version to compile examples against (optional)])
+ AC_ARG_WITH([gtk],
+ AC_HELP_STRING([--with-gtk=3.0|2.0],
+ [which gtk+ version to compile against (default: 2.0)]),
+ [case "$with_gtk" in
+ 2.0|3.0) ;;
+ *) AC_MSG_ERROR([invalid gtk+ version specified]);;
+ esac],
+ [with_gtk=2.0])
+ AC_MSG_RESULT([$with_gtk])
+ PKG_CHECK_MODULES(GTK, gtk+-x11-$with_gtk, HAVE_GTK=yes, HAVE_GTK=no)
+fi
AM_CONDITIONAL(HAVE_GTK, test "x$HAVE_GTK" = "xyes")
dnl Needed for GtkBuilder to autoconnect signals