summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSreerenj Balachandran <sreerenj.balachandran@intel.com>2012-08-08 17:10:28 +0300
committerTim-Philipp Müller <tim@centricular.net>2012-08-21 10:24:45 +0100
commitc803ca4af55520e8eb7c69911491ae118c3a4fd8 (patch)
tree15259e2cbc174dbd126692e0fdbf8f5b8c00c120 /configure.ac
parent38c749ca2fee21d66ff6bae848146007fbd0e52e (diff)
downloadgstreamer-plugins-bad-c803ca4af55520e8eb7c69911491ae118c3a4fd8.tar.gz
wayland: More fixes based on wayland-0.95.0 and gstreamer-1.0 apis
- bump wayland version to 0.95.0 which will lead to stable 1.0 release - avoid memcopy and use propose_allocation for GstBufferPool allocation - using WaylandBufferPool - shm: Allocate shm buffers through new wl_shm_pool interface (the shm buffer allocation is a two step process now: first allocate a wl_shm_pool, then allocate a buffer from the pool) https://bugzilla.gnome.org/show_bug.cgi?id=681453
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9803a15ef..5c71f1411 100644
--- a/configure.ac
+++ b/configure.ac
@@ -898,7 +898,7 @@ AG_GST_CHECK_FEATURE(DIRECTFB, [directfb], dfbvideosink , [
dnl **** Wayland ****
translit(dnm, m, l) AM_CONDITIONAL(USE_WAYLAND, true)
AG_GST_CHECK_FEATURE(WAYLAND, [wayland sink], wayland , [
- PKG_CHECK_MODULES(WAYLAND, wayland-server <= 0.85.0 wayland-client <= 0.85.0, [
+ PKG_CHECK_MODULES(WAYLAND, wayland-server >= 0.95.0 wayland-client >= 0.95.0, [
AC_CHECK_HEADER(wayland-client.h, HAVE_WAYLAND_CLIENT="yes", HAVE_WAYLAND_CLIENT="no")
AC_CHECK_HEADER(wayland-client-protocol.h, HAVE_WAYLAND_CLIENT_PROTOCOL="yes", HAVE_WAYLAND_CLIENT_PROTOCOL="no")
if test "x$HAVE_WAYLAND_CLIENT" = "xno"; then