summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2010-08-11 11:39:35 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2010-08-11 11:39:35 +0200
commitdd26f378b01d679834f12935efc7093fb5807956 (patch)
tree976e687ce262734926de83e0f50d4b199b2a1a3e /configure.ac
parent15098331412ceb982c24b89bb4346354fb56433c (diff)
downloadgstreamer-plugins-bad-dd26f378b01d679834f12935efc7093fb5807956.tar.gz
configure: Fix the CELT check to actually succeed if CELT >= 0.5 is available
Also remove the AC_MSG_RESULTS([no]), pkg-config does this for us already.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9697ae5be..facc63b28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -573,20 +573,23 @@ translit(dnm, m, l) AM_CONDITIONAL(USE_CELT, true)
AG_GST_CHECK_FEATURE(CELT, [celt], celt, [
PKG_CHECK_MODULES(CELT, celt >= 0.5.0, [
AC_DEFINE([HAVE_CELT], 1, [Define if libcelt 0.5 is installed])
+ HAVE_CELT="yes"
], [
- AC_MSG_RESULT(no)
+ HAVE_CELT="no"
])
PKG_CHECK_MODULES(CELT_0_7, celt >= 0.7.0, [
AC_DEFINE([HAVE_CELT_0_7], 1, [Define if libcelt 0.7 is installed])
], [
- AC_MSG_RESULT(no)
+ dnl to prevent an error
+ true
])
PKG_CHECK_MODULES(CELT_0_8, celt >= 0.8.0, [
AC_DEFINE([HAVE_CELT_0_8], 1, [Define if libcelt 0.8 is installed])
], [
- AC_MSG_RESULT(no)
+ dnl to prevent an error
+ true
])
AC_SUBST(CELT_CFLAGS)
AC_SUBST(CELT_LIBS)