summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2016-06-06 15:10:05 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2016-06-21 13:46:00 -0400
commit398f7059fc8eb226f3aa67287ef466328cfd1e94 (patch)
tree7031283ad2201f2885218fcf2acb44ee2a5533d3 /configure.ac
parentcf6a517d41eb76e792bd76ae34bda08be401c499 (diff)
downloadgstreamer-plugins-bad-398f7059fc8eb226f3aa67287ef466328cfd1e94.tar.gz
webrtcdsp: Add WebRTC Audio Processing support
This DSP library can be used to enhance voice signal for real time communication call. In implements multiple filters like noise reduction, high pass filter, echo cancellation, automatic gain control, etc. The webrtcdsp element can be used along, or with the help of the webrtcechoprobe if echo cancellation is enabled. The echo probe should be placed as close as possible to the audio sink, while the DSP is generally place close to the audio capture. For local testing, one can use an echo loop pipeline like the following: autoaudiosrc ! webrtcdsp ! webrtcechoprobe ! autoaudiosink This pipeline should produce a single echo rather then repeated echo. Those elements works if they are placed in the same top level pipeline. https://bugzilla.gnome.org/show_bug.cgi?id=767800
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 88918a898..86655c3ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3355,6 +3355,19 @@ AG_GST_CHECK_FEATURE(X265, [x265 plug-in], x265, [
AG_GST_PKG_CHECK_MODULES(X265, x265)
])
+dnl *** WebRTC Audio Processing ***
+dnl Note: We test for a specific version as there is no API stability
+translit(dnm, m, l) AM_CONDITIONAL(USE_WEBRTCDSP, true)
+AG_GST_CHECK_FEATURE(WEBRTCDSP, [WebRTC Audio Processing], webrtcdsp, [
+ AC_LANG_PUSH([C++])
+ old_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS=-std=c++11 $CPPFLAGS
+ AG_GST_PKG_CHECK_MODULES(WEBRTCDSP, webrtc-audio-processing = 0.2)
+ AC_CHECK_HEADER([typeindex],[],[HAVE_WEBRTCDSP=no])
+ CPPFLAGS=$old_CPPFLAGS
+ AC_LANG_POP([C++])
+])
+
else
dnl not building plugins with external dependencies,
@@ -3751,6 +3764,7 @@ ext/x265/Makefile
ext/xvid/Makefile
ext/zbar/Makefile
ext/dtls/Makefile
+ext/webrtcdsp/Makefile
po/Makefile.in
docs/Makefile
docs/plugins/Makefile