summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@gnome.org>2016-02-23 15:11:36 +0100
committerThibault Saunier <tsaunier@gnome.org>2016-03-27 19:28:00 +0200
commitc32e74fd8aadf7e8e5499a3cc7f01a35ad2f0394 (patch)
tree5221e1d62c55b5d021c1bb1c5b155a7262dbfd07 /configure.ac
parent21023800ca7fd1f36388cbb849aeac6558c9d6c6 (diff)
downloadgstreamer-plugins-bad-c32e74fd8aadf7e8e5499a3cc7f01a35ad2f0394.tar.gz
lv2: Port filters to GStreamer 1.0 and use lilv instead of slv2
Properly separate files as we will not have only one single base class for all elements as we used to with 0.10, but the same way it is done with ladspa, we subclass GstAudioFilter, GstBaseSource etc... https://bugzilla.gnome.org/show_bug.cgi?id=678207
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index eac6852f2..78bb9d0cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -453,7 +453,8 @@ GST_PLUGINS_NONPORTED=" cdxaparse \
apexsink dc1394 \
musepack nas sdl timidity \
wininet \
- xvid lv2 sndio libvisual"
+ xvid sndio libvisual"
+
AC_SUBST(GST_PLUGINS_NONPORTED)
dnl these are all the gst plug-ins, compilable without additional libs
@@ -2324,9 +2325,9 @@ AG_GST_CHECK_FEATURE(LADSPA, [ladspa], ladspa, [
dnl *** LV2 ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LV2, true)
AG_GST_CHECK_FEATURE(LV2, [lv2], lv2, [
- PKG_CHECK_MODULES(SLV2, slv2 >= 0.6.6, HAVE_LV2="yes", HAVE_LV2="no")
- AC_SUBST(SLV2_CFLAGS)
- AC_SUBST(SLV2_LIBS)
+ PKG_CHECK_MODULES(LILV, lilv-0 >= 0.6.6, HAVE_LV2="yes", HAVE_LV2="no")
+ AC_SUBST(LILV_CFLAGS)
+ AC_SUBST(LILV_LIBS)
])
dnl *** libde265 ***