summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Tretter <m.tretter@pengutronix.de>2016-10-19 12:39:36 +0200
committerVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2016-11-23 16:43:28 +0100
commit12e82aac28d0467844233f3cbc9d8ae7c08cd05c (patch)
treed334f236a0cc19bd2dfc82219a5a4c5dfd5fc55f /configure.ac
parentad661999ad2c79a5d7721f0eb1e7f1f83a304224 (diff)
downloadgstreamer-plugins-bad-12e82aac28d0467844233f3cbc9d8ae7c08cd05c.tar.gz
kmssink: remove dependency on libkms
libkms should not be used, because it imposes limitations on the DRM API, especially regarding bpp and stride. Instead the DRM IOCTL should be used directly. Switch from libkms to the IOCTL interface. Set bpp and height for framebuffer allocation to properly handle planar video formats. https://bugzilla.gnome.org/show_bug.cgi?id=773473 Signed-off-by: Víctor Jáquez <vjaquez@igalia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1598c3c72..ff49004b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2438,7 +2438,7 @@ dnl *** kms ***
translit(dnm, m, l) AM_CONDITIONAL(USE_KMS, true)
AG_GST_CHECK_FEATURE(KMS, [drm/kms libraries], kms, [
AG_GST_PKG_CHECK_MODULES(GST_ALLOCATORS, gstreamer-allocators-1.0)
- PKG_CHECK_MODULES([KMS_DRM], [libdrm >= 2.4.55 libkms], HAVE_KMS=yes, HAVE_KMS=no)
+ PKG_CHECK_MODULES([KMS_DRM], [libdrm >= 2.4.55], HAVE_KMS=yes, HAVE_KMS=no)
])
dnl *** ladspa ***