summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuis de Bethencourt <luisbg@osg.samsung.com>2016-11-15 11:59:45 +0000
committerLuis <luis@goodgumbo>2016-11-15 16:01:22 +0100
commit2132b6b4529841de3ac619022b261507c95629c8 (patch)
tree032427386ccbeecd3d03d935d4b916aefdc2a3f3 /configure.ac
parent9f690fa241d32ff53aa26819a84f97717a338387 (diff)
downloadgstreamer-plugins-bad-2132b6b4529841de3ac619022b261507c95629c8.tar.gz
configure: fix build if libdrm is not available
If the NOT_FOUND part of the check PKG_CHECK_MODULES is not written, it defaults to error. Addind the else clause of this check as HAVE_WAYLAND="no" https://bugzilla.gnome.org/show_bug.cgi?id=773927
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 27084affb..334577123 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2260,19 +2260,20 @@ translit(dnm, m, l) AM_CONDITIONAL(USE_WAYLAND, true)
AC_PATH_PROG([wayland_scanner], [wayland-scanner])
AG_GST_CHECK_FEATURE(WAYLAND, [wayland sink], wayland , [
PKG_CHECK_MODULES(WAYLAND, wayland-client >= 1.4.0, [
- PKG_CHECK_MODULES([WAYLAND_DRM], [libdrm >= 2.4.55])
- PKG_CHECK_MODULES(WAYLAND_PROTOCOLS, wayland-protocols >= 1.4, [
- if test "x$wayland_scanner" != "x"; then
- HAVE_WAYLAND="yes"
- AC_SUBST(WAYLAND_PROTOCOLS_DATADIR, `$PKG_CONFIG --variable=pkgdatadir wayland-protocols`)
- else
- AC_MSG_RESULT([wayland-scanner is required to build the wayland plugin])
- HAVE_WAYLAND="no"
- fi
- ],
+ PKG_CHECK_MODULES([WAYLAND_DRM], [libdrm >= 2.4.55], [
+ PKG_CHECK_MODULES(WAYLAND_PROTOCOLS, wayland-protocols >= 1.4, [
+ if test "x$wayland_scanner" != "x"; then
+ HAVE_WAYLAND="yes"
+ AC_SUBST(WAYLAND_PROTOCOLS_DATADIR, `$PKG_CONFIG --variable=pkgdatadir wayland-protocols`)
+ else
+ AC_MSG_RESULT([wayland-scanner is required to build the wayland plugin])
+ HAVE_WAYLAND="no"
+ fi
+ ],
+ [ HAVE_WAYLAND="no"
+ ])],
[ HAVE_WAYLAND="no"
- ])],
- [ HAVE_WAYLAND="no"
+ ])
])
])