summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2016-07-01 00:07:23 +1000
committerMatthew Waters <matthew@centricular.com>2016-11-08 15:14:26 +1100
commit4f6c226bd24ae3ef66bd8f4c17b001444c9b0bf1 (patch)
treef4e7cf1170b9a3036a13354d8caea46d9fac993b /configure.ac
parente4916fb1ef8e5ecc075978b98f50bd799faf83e0 (diff)
downloadgstreamer-plugins-bad-4f6c226bd24ae3ef66bd8f4c17b001444c9b0bf1.tar.gz
gl/x11: use xcb instead of libX11
- xcb is supposedly thread-safe! videotestsrc ! glimagesink now doesn't spuriously result in a 'call XInitThreads()' error however if anybody else is using X11, then XInitThreads() still needs to be called and multiple glimagesink's still need XInitThreads(). Everything still takes libX11 handles as they are compatible with the xcb variants. Unfortunately we cannot move fully over to xcb due to GLX being entirely based on Xlib. It's also impossible to transform a xcb_connection to a Display which means we require X11 handles.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index e5df43cc0..7cdb1e28f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -692,7 +692,7 @@ AC_ARG_ENABLE([dispmanx],
*) AC_MSG_ERROR([bad value ${enableval} for --enable-dispmanx]) ;;
esac],[NEED_DISPMANX=auto])
-AG_GST_PKG_CHECK_MODULES(X, x11)
+AG_GST_PKG_CHECK_MODULES(X11_XCB, x11-xcb)
save_CPPFLAGS="$CPPFLAGS"
save_LIBS="$LIBS"
@@ -847,7 +847,7 @@ if test "x$HAVE_GLES2" = "xno"; then
fi
dnl X, GLX and OpenGL
-if test "x$HAVE_X" = "xno"; then
+if test "x$HAVE_X11_XCB" = "xno"; then
if test "x$NEED_GLX" = "xyes"; then
AC_MSG_ERROR([Building the GLX backend without X11 is unsupported])
fi
@@ -1002,7 +1002,7 @@ case $host in
AC_MSG_ERROR([WGL is not available on unix])
fi
- if test "x$HAVE_X" = "xno"; then
+ if test "x$HAVE_X11_XCB" = "xno"; then
if test "x$HAVE_WAYLAND_EGL" = "xno"; then
AC_MSG_WARN([X or Wayland is required for OpenGL support])
fi
@@ -1023,10 +1023,10 @@ case $host in
fi
fi
- if test "x$HAVE_X" = "xyes" -a "x$HAVE_EGL_RPI" = "xno"; then
+ if test "x$HAVE_X11_XCB" = "xyes" -a "x$HAVE_EGL_RPI" = "xno"; then
if test "x$NEED_X11" != "xno"; then
- GL_LIBS="$GL_LIBS $X_LIBS"
- GL_CFLAGS="$GL_CFLAGS $X_CFLAGS"
+ GL_LIBS="$GL_LIBS $X11_XCB_LIBS"
+ GL_CFLAGS="$GL_CFLAGS $X11_XCB_CFLAGS"
HAVE_WINDOW_X11=yes
fi
fi
@@ -1110,10 +1110,10 @@ case $host in
fi
if test "x$USE_GLX" = "xyes"; then
- if test "x$HAVE_X" = "xyes"; then
+ if test "x$HAVE_X11_XCB" = "xyes"; then
if test "x$NEED_X11" != "xno"; then
- GL_LIBS="$GL_LIBS $X_LIBS"
- GL_CFLAGS="$GL_CFLAGS $X_CFLAGS"
+ GL_LIBS="$GL_LIBS $X11_XCB_LIBS"
+ GL_CFLAGS="$GL_CFLAGS $X11_XCB_CFLAGS"
HAVE_WINDOW_X11=yes
fi
fi