summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2016-07-07 12:31:03 -0400
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2016-07-07 12:31:03 -0400
commit928dcd93efe419ccaba8a0ccf429e5fc19f8d70c (patch)
tree6b66573d23565685a7bd9d65b7b46fa9c8b01554 /configure.ac
parent17e8533064e4b3f3f9f37d4d11201fbdfa37c0c6 (diff)
downloadgstreamer-plugins-bad-928dcd93efe419ccaba8a0ccf429e5fc19f8d70c.tar.gz
webrtcdsp: Add Android GNUSTL support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index fad854f8f..5dc341b23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3368,12 +3368,26 @@ dnl *** WebRTC Audio Processing ***
dnl Note: We test for a specific version as there is no API stability
translit(dnm, m, l) AM_CONDITIONAL(USE_WEBRTCDSP, true)
AG_GST_CHECK_FEATURE(WEBRTCDSP, [WebRTC Audio Processing], webrtcdsp, [
+
+ AG_GST_PKG_CHECK_MODULES(WEBRTCDSP, webrtc-audio-processing >= 0.2 webrtc-audio-processing < 0.4)
+
+ # On Android, C++ headers comes with the STL implementation
+ AS_CASE(["${host}"],
+ [*android*],
+ [
+ PKG_CHECK_MODULES(GNUSTL, gnustl, [
+ WEBRTCDSP_CFLAGS="$WEBRTCDSP_CFLAGS $GNUSTL_CFLAGS"
+ WEBRTCDSP_LIBS="$WEBRTCDSP_LIBS $GNUSTL_LIBS"])
+ ])
+ AC_SUBST([WEBRTCDSP_CFLAGS])
+ AC_SUBST([WEBRTCDSP_LIBS])
+
AC_LANG_PUSH([C++])
old_CPPFLAGS=$CPPFLAGS
- CPPFLAGS="-std=c++11 $CPPFLAGS"
- AG_GST_PKG_CHECK_MODULES(WEBRTCDSP, webrtc-audio-processing >= 0.2 webrtc-audio-processing < 0.4)
- AC_CHECK_HEADER([typeindex],[],[HAVE_WEBRTCDSP=no])
+ old_LDFLAGS=$GNUSTL_LIBS
+ CPPFLAGS="-std=c++11 $CPPFLAGS $GNUSTL_CFLAGS"
CPPFLAGS=$old_CPPFLAGS
+ LDFLAGS=$old_LDFLAGS
AC_LANG_POP([C++])
])