summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2016-09-06 20:00:07 +1000
committerMatthew Waters <matthew@centricular.com>2016-09-07 00:15:02 +1000
commitf3b0b22c48d03727475942e82a0230013a7951ca (patch)
tree4074ebc72716f281e6c50cfc577d2e14555ce6b3 /configure.ac
parent7fa2668adf377b1909907a22e3f27a479c4ddafa (diff)
downloadgstreamer-plugins-bad-f3b0b22c48d03727475942e82a0230013a7951ca.tar.gz
build/vulkan: fix winsys detection based on the previously set variables
The X11/Wayland winsys checks weren't being used to enable the vulkan element. Use them.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a1f8c1e03..86ca31414 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2998,14 +2998,15 @@ AG_GST_CHECK_FEATURE(QT, [Qt elements], qt, [
dnl *** Vulkan ***
translit(dnm, m, l) AM_CONDITIONAL(USE_VULKAN, true)
AG_GST_CHECK_FEATURE(VULKAN, [Vulkan elements], vulkan, [
- HAVE_VULKAN=no
AC_CHECK_HEADER(vulkan/vulkan.h, [
AC_CHECK_LIB(vulkan, vkCreateDevice, [
VULKAN_LIBS="-lvulkan"
AC_SUBST(VULKAN_LIBS)
- dnl TODO check platform support (x11, win32, wayland, android, etc)
- if test "x$HAVE_XCB" = "xyes"; then
- HAVE_VULKAN=yes
+ if test "x$GST_VULKAN_HAVE_WINDOW_XCB" = "x1"; then
+ HAVE_VULKAN="yes"
+ fi
+ if test "x$GST_VULKAN_HAVE_WINDOW_WAYLAND" = "x1"; then
+ HAVE_VULKAN="yes"
fi
], [])
], [])