summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathieu Duponchelle <mathieu.duponchelle@opencreed.com>2016-11-16 13:18:53 -0300
committerThibault Saunier <thibault.saunier@osg.samsung.com>2016-11-17 13:25:33 -0300
commit087d9bc37606e98fc4413bfa2baa1d9e9efda9bf (patch)
tree3a8837a8261f2e9412044955a888768598b31545 /configure.ac
parenta7b0669ce8fe62e1584ff582fe000c2538e808cc (diff)
downloadgstreamer-plugins-bad-087d9bc37606e98fc4413bfa2baa1d9e9efda9bf.tar.gz
Adds a new Image Quality Assessment plugin.
It only offers one metric for now, "dssim", available if https://github.com/pornel/dssim was installed on the system at the time the plugin was compiled. The spearman correlation for dssim against the TID2008 dataset is 0.81, against 0.70 for the old ssim implementation, and it runs 15 times faster. https://bugzilla.gnome.org/show_bug.cgi?id=751324
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c48b86cda..35ef31f8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -358,6 +358,23 @@ AC_SUBST(EXIF_LIBS)
AC_SUBST(EXIF_CFLAGS)
AM_CONDITIONAL(USE_EXIF, test "x$HAVE_EXIF" = "xyes")
+AG_GST_CHECK_FEATURE(IQA, [iqa], iqa , [
+ PKG_CHECK_MODULES(DSSIM, dssim, [
+ HAVE_DSSIM="yes"
+ HAVE_IQA="yes"
+ ], [
+ HAVE_DSSIM="no"
+ HAVE_IQA="no"
+ ])
+
+ AM_CONDITIONAL(HAVE_DSSIM, test "x$HAVE_DSSIM" = "xyes")
+ if test "x$HAVE_DSSIM" = "xyes"; then
+ AC_DEFINE(HAVE_DSSIM, 1, [Define if you have dssim library])
+ fi
+ AC_SUBST(DSSIM_LIBS)
+ AC_SUBST(DSSIM_CFLAGS)
+])
+
dnl Orc
ORC_CHECK([0.4.17])
@@ -3525,6 +3542,7 @@ AM_CONDITIONAL(USE_GSM, false)
AM_CONDITIONAL(USE_GTK3, false)
AM_CONDITIONAL(USE_GTK3_GL, false)
AM_CONDITIONAL(USE_HLS, false)
+AM_CONDITIONAL(USE_IQA, false)
AM_CONDITIONAL(USE_KATE, false)
AM_CONDITIONAL(USE_KMS, false)
AM_CONDITIONAL(USE_TIGER, false)
@@ -3846,6 +3864,7 @@ ext/flite/Makefile
ext/fluidsynth/Makefile
ext/gsm/Makefile
ext/hls/Makefile
+ext/iqa/Makefile
ext/kate/Makefile
ext/ladspa/Makefile
ext/lv2/Makefile