summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2016-02-04 00:08:57 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-02-07 22:49:36 +0530
commit3f7e29d5b32f20dff75a58186533e40bb0ed4081 (patch)
tree72a09d2b4fca7cef8b5f2df4984e9a12d45fb107 /configure.ac
parentc5c69dcc55d180b8d271ba58e1425cb82c6c81b0 (diff)
downloadgstreamer-plugins-bad-3f7e29d5b32f20dff75a58186533e40bb0ed4081.tar.gz
Add new 'proxy' element to stream data between pipelines
This keep-it-simple plugin is useful when you want to pipe arbitrary data to a different pipeline within the same process. Some advantages over appsink/appsrc, the inter elements, etc: * Ease of use. Buffers, events, and caps are transmitted as-is without copying or serialization. * Enables zerocopy (especially DMABUF) transparently without any special-casing. * Enables usage with sinks or elements that are unreliable and may throw errors and need re-initialization, such as a network sink, a USB device sink (v4l2), etc. * Transmits arbitrary data, not just audio/video/subs * Can easily implement 1 producer pipeline -> N dynamic consumer pipelines within a single process when combined with the `tee` element. All queries, events, buffers, and buffer lists are proxied. State changes, clocks, and base times for the two pipelines are independent since the upstream and downstreams continue to be different pipelines. https://bugzilla.gnome.org/show_bug.cgi?id=788200
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3844a4c02..1516f66b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -461,6 +461,7 @@ AG_GST_CHECK_PLUGIN(netsim)
AG_GST_CHECK_PLUGIN(onvif)
AG_GST_CHECK_PLUGIN(pcapparse)
AG_GST_CHECK_PLUGIN(pnm)
+AG_GST_CHECK_PLUGIN(proxy)
AG_GST_CHECK_PLUGIN(rawparse)
AG_GST_CHECK_PLUGIN(removesilence)
AG_GST_CHECK_PLUGIN(sdp)
@@ -2663,6 +2664,7 @@ gst/netsim/Makefile
gst/onvif/Makefile
gst/pcapparse/Makefile
gst/pnm/Makefile
+gst/proxy/Makefile
gst/rawparse/Makefile
gst/removesilence/Makefile
gst/sdp/Makefile