summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Sauer <ensonic@users.sf.net>2014-10-20 11:22:54 +0200
committerStefan Sauer <ensonic@users.sf.net>2014-10-20 11:22:54 +0200
commitca5971850d7270cec2eb8d0629c634844e6dfe57 (patch)
tree3056ba0f6ec86843705881582e0b4eb432105f19 /configure.ac
parenta4d8efde0fd2abdc970f5902375f2e9697e58e2c (diff)
downloadgstreamer-plugins-bad-ca5971850d7270cec2eb8d0629c634844e6dfe57.tar.gz
configure: add pthread to the configure check for openh264
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af0435a43..76c430c4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2573,8 +2573,11 @@ dnl *** openh264 ***
translit(dnm, m, l) AM_CONDITIONAL(USE_OPENH264, true)
AG_GST_CHECK_FEATURE(OPENH264, [openh264 library], openh264, [
HAVE_OPENH264="yes"
+ saved_LIBS="$LIBS"
+ LIBS="-lpthread $LIBS"
AG_GST_CHECK_LIBHEADER(OPENH264, openh264, WelsSnprintf, ,wels/codec_api.h,
OPENH264_LIBS="-lopenh264", HAVE_OPENH264="no")
+ LIBS=$saved_LIBS
AC_SUBST(OPENH264_LIBS)
])