summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2017-10-20 11:44:50 +0200
committerSebastian Dröge <sebastian@centricular.com>2017-10-20 12:27:30 +0200
commite5977b8794428ee1e37763738af5d880d9482fcd (patch)
tree646c642560b1727edb0cdbf8823c8e88acd0da22 /configure.ac
parentbff2d834a4a38f64e555cee3d0144fde6c515acd (diff)
downloadgstreamer-plugins-bad-e5977b8794428ee1e37763738af5d880d9482fcd.tar.gz
openjpeg: Remove compatibility with openjpeg 2.0
Everyone seems to be shipping 2.1 as the oldest v2 version, even debian oldstable (jessie). Also remove an unneeded (debug?) #include <stdio.h>. https://bugzilla.gnome.org/show_bug.cgi?id=788703
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 2 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 7bef68816..744c9cd43 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2864,14 +2864,8 @@ dnl *** OpenJPEG ***
translit(dnm, m, l) AM_CONDITIONAL(USE_OPENJPEG, true)
AG_GST_CHECK_FEATURE(OPENJPEG, [openjpeg library], openjpeg, [
HAVE_OPENJPEG="no"
- AG_GST_PKG_CHECK_MODULES(OPENJPEG, libopenjp2 >= 2.0)
- if test x"$HAVE_OPENJPEG" = x"yes"; then
- dnl minor API changes in v2.1
- AG_GST_PKG_CHECK_MODULES(OPENJPEG_2_1, libopenjp2 >= 2.1)
- if test x"$HAVE_OPENJPEG_2_1" = x"yes"; then
- AC_DEFINE([HAVE_OPENJPEG_2_1], 1, [Define if OpenJPEG 2.1 is used])
- fi
- else
+ AG_GST_PKG_CHECK_MODULES(OPENJPEG, libopenjp2 >= 2.1)
+ if test x"$HAVE_OPENJPEG" != x"yes"; then
# Fallback to v1.5
OPENJPEG_LIBS=""
PKG_CHECK_MODULES(OPENJPEG, libopenjpeg1,