summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-11-22 12:14:44 +0900
committerTim-Philipp Müller <tim@centricular.com>2018-11-25 23:31:37 +0000
commit6bf5ba993d170c5a267fab9ce69e7eac68cf6759 (patch)
treed96b6a636a81f3fde5e88ea3005314faeed61e85 /configure.ac
parent6051c47bfe3d98f96012f79e63f2b7fae618379e (diff)
downloadgstreamer-plugins-bad-6bf5ba993d170c5a267fab9ce69e7eac68cf6759.tar.gz
nvenc: Add meson build with Windows support
Note that, since Nvidia does not provide nvEncodeAPI.lib file, find_library() couldn't be used for build on Windows. This patch changes to load nvEncodeAPI(64).dll or libnvidia-encode.so in runtime
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 5adc154a4..8b281c9f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1003,26 +1003,6 @@ AG_GST_CHECK_FEATURE(NVDEC, [nvdec], nvdec, [
dnl *** NVENC ***
translit(dnm, m, l) AM_CONDITIONAL(USE_NVENC, true)
AG_GST_CHECK_FEATURE(NVENC, [NVIDIA Encode API], nvenc, [
- dnl nvEncodeAPI.h header
- HAVE_NVENCODEAPI_H=no
- AC_ARG_VAR(NVENCODE_CFLAGS, [C compiler flags for NvEncodeAPI.h])
- save_CPPFLAGS="$CPPFLAGS"
- CPPFLAGS="$NVENCODE_CFLAGS $save_CPPFLAGS"
- AC_CHECK_HEADER([nvEncodeAPI.h], [
- AC_PREPROC_IFELSE([AC_LANG_SOURCE([[#include <nvEncodeAPI.h>
- #if NVENCAPI_MAJOR_VERSION < 5
- #error "Need nvEncodeAPI.h >= 5.0"
- #endif
- ]])], [
- HAVE_NVENCODEAPI_H=yes
- ], [
- AC_MSG_WARN([nvEncodeAPI.h must be >= 5.0])
- ])
- ],
- AC_MSG_WARN([Could not find nvEncodeAPI.h]))
- AC_SUBST(NVENCODE_CFLAGS)
- CPPFLAGS="$save_CPPFLAGS"
-
dnl libnvnidia-encode library
HAVE_NVENCODE_LIB=no
AC_ARG_VAR(NVENCODE_LIBS, [linker flags for nvidia-encode])
@@ -1039,7 +1019,6 @@ AG_GST_CHECK_FEATURE(NVENC, [NVIDIA Encode API], nvenc, [
-a "x$HAVE_CUDART_H" = "xyes" \
-a "x$HAVE_CUDA_LIB" = "xyes" \
-a "x$HAVE_CUDART_LIB" = "xyes" \
- -a "x$HAVE_NVENCODEAPI_H" = "xyes" \
-a "x$HAVE_NVENCODE_LIB" = "xyes"; then
HAVE_NVENC="yes"
if test "x$GST_GL_HAVE_API_GL" = "x1"; then