summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilippe Normand <philn@igalia.com>2019-01-21 10:57:57 +0000
committerTim-Philipp Müller <tim@centricular.com>2019-01-22 11:13:13 +0000
commitc357e1211865bc7e76ddd740611669437f8496e2 (patch)
tree372c94856543aea6561ddcd638d8813b0d72260d /configure.ac
parentdc2810522026042ccf589e309c357d912140b12c (diff)
downloadgstreamer-plugins-bad-c357e1211865bc7e76ddd740611669437f8496e2.tar.gz
wpe: Add autotools build support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 276484f57..9d1a067f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2305,6 +2305,15 @@ AG_GST_CHECK_FEATURE(WEBRTC, [WebRTC], webrtc, [
])
])
+dnl *** WPE ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_WPE, true)
+AG_GST_CHECK_FEATURE(WPE, [WPE plug-in], wpe, [
+PKG_CHECK_MODULES(WPE, [ wpe-webkit-0.1 >= 2.22 wpebackend-fdo-0.1 egl xkbcommon ], [
+ HAVE_WPE="yes" ], [
+ HAVE_WPE="no"
+ ])
+])
+
dnl *** usrsctp ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SCTP, true)
AG_GST_CHECK_FEATURE(SCTP, [sctp plug-in], sctp, [
@@ -2695,6 +2704,7 @@ ext/zbar/Makefile
ext/dtls/Makefile
ext/webrtc/Makefile
ext/webrtcdsp/Makefile
+ext/wpe/Makefile
ext/ttml/Makefile
po/Makefile.in
docs/Makefile