summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <jan@centricular.com>2018-05-05 14:32:59 +0000
committerJan Schmidt <jan@centricular.com>2018-05-06 00:35:23 +1000
commit0b9517cc96b745709f30f99f22172553d9f5110f (patch)
tree6692e262dd06df411f05a05e9c779b3327ce6350 /configure.ac
parent0dcd431c0e262af2dd98dcfa04f99e114d6c4933 (diff)
downloadgstreamer-plugins-bad-0b9517cc96b745709f30f99f22172553d9f5110f.tar.gz
waylandsink: Only build if gtk-3.0 was built with wayland target
Check in configure if the gtk-3.0 has wayland support, and don't build the waylandsink example if it doesn't.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8693f09f2..1d386f96f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -306,6 +306,7 @@ dnl *** set variables based on configure arguments ***
dnl GTK is optional and used in examples
HAVE_GTK3=NO
+HAVE_GTK3_WAYLAND=""
if test "x$BUILD_EXAMPLES" = "xyes"; then
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.4, HAVE_GTK3=yes, HAVE_GTK3=no)
if test "x$HAVE_GTK3" = "xyes"; then
@@ -314,12 +315,15 @@ if test "x$BUILD_EXAMPLES" = "xyes"; then
AC_SUBST(GTK_VERSION)
GTK_PREFIX=`$PKG_CONFIG --variable=prefix gdk-pixbuf-2.0`
AC_SUBST(GTK_BASE_DIR)
+ GTK3_TARGETS=`$PKG_CONFIG --variable=targets gtk+-3.0`
+ case "$GTK3_TARGETS" in *wayland*) HAVE_GTK3_WAYLAND="1" ;; esac
fi
fi
AC_SUBST(GTK3_LIBS)
AC_SUBST(GTK3_CFLAGS)
AC_SUBST(HAVE_GTK3)
AM_CONDITIONAL(HAVE_GTK3, test "x$HAVE_GTK3" = "xyes")
+AM_CONDITIONAL(HAVE_GTK3_WAYLAND, test "x$HAVE_GTK3_WAYLAND" = "x1")
dnl x11 is optional for librfb
HAVE_X11=NO