summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Hervey <edward@centricular.com>2018-03-08 15:22:47 +0100
committerEdward Hervey <bilboed@bilboed.com>2018-05-28 11:54:17 +0200
commit2550718f59c2faee0540ec88821b0b9f6c738fc9 (patch)
tree9585ac8db781be26dbfe315d17712cee91ffb79e /configure.ac
parented7a98d45b5ed46605759bf860fac0027ccf3951 (diff)
downloadgstreamer-plugins-bad-2550718f59c2faee0540ec88821b0b9f6c738fc9.tar.gz
ext: New ccextractor element
Allows extracting GstVideoCaptionMeta from a stream and outputs it to a standalone stream. Part of a new 'ext' closedcaption plugin, since more features are going to be added, which will depend on external dependencies such as pango.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2862feb5f..d470287bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1994,6 +1994,12 @@ AG_GST_CHECK_FEATURE(OPUS, [opus], opus, [
AC_SUBST(OPUS_LIBS)
])
+dnl *** pango ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_PANGO, true)
+AG_GST_CHECK_FEATURE(PANGO, [Pango font rendering], pango, [
+ AG_GST_PKG_CHECK_MODULES(PANGO, pango >= 1.22.0 pangocairo >= 1.22.0)
+])
+
dnl *** rsvg ***
translit(dnm, m, l) AM_CONDITIONAL(USE_RSVG, true)
AG_GST_CHECK_FEATURE(RSVG, [rsvg decoder], rsvg, [
@@ -2416,6 +2422,7 @@ AM_CONDITIONAL(USE_OPENJPEG, false)
AM_CONDITIONAL(USE_OPENMPT, false)
AM_CONDITIONAL(USE_OPENNI2, false)
AM_CONDITIONAL(USE_OPUS, false)
+AM_CONDITIONAL(USE_PANGO, false)
AM_CONDITIONAL(USE_WILDMIDI, false)
AM_CONDITIONAL(USE_SMOOTHSTREAMING, false)
AM_CONDITIONAL(USE_SNDFILE, false)
@@ -2674,6 +2681,7 @@ ext/aom/Makefile
ext/bs2b/Makefile
ext/bz2/Makefile
ext/chromaprint/Makefile
+ext/closedcaption/Makefile
ext/colormanagement/Makefile
ext/curl/Makefile
ext/dash/Makefile