summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels De Graef <niels.degraef@barco.com>2019-03-01 09:56:24 +0100
committerNiels De Graef <nielsdegraef@gmail.com>2019-03-04 10:58:54 +0000
commit67bb17e4fae76f8f662fdd69bba6cdaaf37a90fa (patch)
tree4db52e5703fdf86981c9a7ba4b84aaaebc1f2a83 /configure.ac
parentc461f22befeae020b4411907164925a4250b583f (diff)
downloadgstreamer-plugins-bad-67bb17e4fae76f8f662fdd69bba6cdaaf37a90fa.tar.gz
waylandsink: Implement XDG-shell stable support
[wl_shell] is officially [deprecated], so provide support for the XDG-shell protocol should be provided by all desktop-like compositors. (In case they don't, we can of course fall back to wl_shell). Note that the [XML spec] is provided by the `wayland-protocols` git repository, which is provided by the Wayland project. Fixes https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/issues/897 [wl_shell]: https://people.freedesktop.org/~whot/wayland-doxygen/wayland/Client/group__iface__wl__shell.html [deprecated]: https://github.com/wayland-project/wayland/commit/698dde195837f3d0844b2725ba4ea8ce9ee7518c [XML spec]: https://github.com/wayland-project/wayland-protocols/blob/master/stable/xdg-shell/xdg-shell.xml
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 90a5bc25c..68a144d8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1319,7 +1319,7 @@ dnl **** Wayland ****
translit(dnm, m, l) AM_CONDITIONAL(USE_WAYLAND, true)
AC_PATH_PROG([wayland_scanner], [wayland-scanner])
AG_GST_CHECK_FEATURE(WAYLAND, [wayland sink], wayland , [
- PKG_CHECK_MODULES(WAYLAND, wayland-client >= 1.11.0 libdrm >= 2.4.55 wayland-protocols >= 1.4, [
+ PKG_CHECK_MODULES(WAYLAND, wayland-client >= 1.11.0 libdrm >= 2.4.55 wayland-protocols >= 1.15, [
if test "x$wayland_scanner" != "x"; then
HAVE_WAYLAND="yes"
AC_SUBST(WAYLAND_PROTOCOLS_DATADIR, `$PKG_CONFIG --variable=pkgdatadir wayland-protocols`)