summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <jan@centricular.com>2018-04-25 02:25:16 +1000
committerJan Schmidt <jan@centricular.com>2018-04-25 02:44:14 +1000
commit8b4a78019d3cdd9fb10439df419300346178b604 (patch)
treef168ff6cf5c7a755da9e179e3c016f5977bd60da /configure.ac
parent02c2b0b275fd5aa84b880c20ba50b8a55ea107ca (diff)
downloadgstreamer-plugins-bad-8b4a78019d3cdd9fb10439df419300346178b604.tar.gz
configure: Fix nvenc GL check
Make the nvenc OpenGL usage rely on the the same condition that the automake USE_OPENGL conditional checks, as the USE_OPENGL doesn't actually get set into the configure script, so it can't check that
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c5fe410ad..8693f09f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,6 +244,7 @@ if test "x$HAVE_GST_GL" = "xyes"; then
case "$GST_GL_APIS" in *gles2*) GST_GL_HAVE_API_GLES2="1" ;; esac
case "$GST_GL_APIS" in "gl"|"gl "*|*" gl"|*" gl "*) GST_GL_HAVE_API_GL="1" ;; esac
fi
+AM_CONDITIONAL(USE_OPENGL, test "x$GST_GL_HAVE_API_GL" = "x1")
AM_CONDITIONAL(HAVE_GST_CHECK, test "x$HAVE_GST_CHECK" = "xyes")
@@ -1050,7 +1051,7 @@ AG_GST_CHECK_FEATURE(NVENC, [NVIDIA Encode API], nvenc, [
-a "x$HAVE_NVENCODEAPI_H" = "xyes" \
-a "x$HAVE_NVENCODE_LIB" = "xyes"; then
HAVE_NVENC="yes"
- if test x"$USE_OPENGL" = x"yes"; then
+ if test "x$GST_GL_HAVE_API_GL" = "x1"; then
dnl cuda-gl interop header
save_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$save_CPPFLAGS $CUDA_CFLAGS"