summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2014-01-10 08:58:27 +0100
committerEdward Hervey <bilboed@bilboed.com>2014-01-10 08:58:27 +0100
commit2e9e8b5c62adf75b933be28c258c6c718b98e40f (patch)
tree87dc40c83e08494b8ccf9ca005f80a0e59077cb8 /configure.ac
parent8b1bd860008a8f7668dfbb4b6750317c01b55d48 (diff)
downloadgstreamer-plugins-bad-2e9e8b5c62adf75b933be28c258c6c718b98e40f.tar.gz
dvb: Use DVB_API_VERSION to know if we have recent enough version
We end up with the same end-result but it's more comprehensible
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6abfab0ab..046994efb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2064,10 +2064,10 @@ dnl *** dvb ***
translit(dnm, m, l) AM_CONDITIONAL(USE_DVB, true)
AG_GST_CHECK_FEATURE(DVB, [DVB Source], dvb, [
AC_MSG_CHECKING([Checking for up to date dvb installation])
- AC_CHECK_HEADER(linux/dvb/frontend.h, [
+ AC_CHECK_HEADER(linux/dvb/version.h, [
AC_MSG_CHECKING([for up-to-date dvb API])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <linux/dvb/frontend.h>]], [[
- #ifndef SYS_DVBC_ANNEX_AC
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <linux/dvb/version.h>]], [[
+ #if DVB_API_VERSION < 5
#error "Incompatible dvb API"
#endif
]])], [ AC_MSG_RESULT(yes)