summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <ystreet00@gmail.com>2014-04-02 09:29:56 +1100
committerMatthew Waters <ystreet00@gmail.com>2014-04-02 09:33:19 +1100
commit21ea26abbe1a137065b67319a3b5da4de4bf3c0e (patch)
tree2d156f02186f8eddb41b8d9dcdb8d6309879198f /configure.ac
parent14e993e745414061f5347d9a876d4c58995f29c0 (diff)
downloadgstreamer-plugins-bad-21ea26abbe1a137065b67319a3b5da4de4bf3c0e.tar.gz
gl/win32: fix detection of GL/wglext.h
Was resulting in 'present but cannot be compiled' errors
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 44286410a..ab60c9a06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -717,7 +717,7 @@ case $host in
LIBS="$LIBS -lgdi32"
AG_GST_CHECK_LIBHEADER(GL, opengl32, glTexImage2D,, GL/gl.h)
AG_GST_CHECK_LIBHEADER(GLU, glu32, gluSphere,, GL/glu.h)
- AC_CHECK_HEADER(GL/wglext.h, HAVE_WGLEXT="yes", HAVE_WGLEXT="no")
+ AC_CHECK_HEADER(GL/wglext.h, HAVE_WGLEXT="yes", HAVE_WGLEXT="no", [#include <GL/gl.h>])
if test "x$HAVE_WGLEXT" = "xyes"; then
HAVE_GL=yes
HAVE_GLU=yes