summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2014-02-09 18:49:49 +0100
committerSebastian Dröge <sebastian@centricular.com>2014-02-09 18:52:24 +0100
commit6799e3b879f359b99f78a2a72fe1880a36bf0ecc (patch)
treeabd8eee9881d81f1b8d8a406a53ea49022cbbc04 /configure.ac
parent6abed8da20eb0a2f4990d064ad923ef735056e84 (diff)
downloadgstreamer-plugins-bad-6799e3b879f359b99f78a2a72fe1880a36bf0ecc.tar.gz
hlsdemux: Prefer to use nettle for decryption but fall-back to libgcrypt
nettle is used by newer versions of gnutls, while older versions of gnutls used libgcrypt. Support both for now as not every distro has nettle yet. nettle is preferred as it is more efficient to use and much smaller.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 23992fcc4..ea8aefb50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2211,7 +2211,19 @@ AG_GST_CHECK_FEATURE(SNDIO, [sndio audio], sndio, [
dnl *** hls ***
translit(dnm, m, l) AM_CONDITIONAL(USE_HLS, true)
AG_GST_CHECK_FEATURE(HLS, [http live streaming plugin], hls, [
- AM_PATH_LIBGCRYPT([1.2.0], [ HAVE_HLS="yes" ], [ HAVE_HLS="no" ])
+ PKG_CHECK_MODULES(NETTLE, nettle,
+ [
+ AC_DEFINE(HAVE_NETTLE, 1, [Define if nettle is available])
+ HAVE_HLS="yes"
+ ], [
+ AM_PATH_LIBGCRYPT([1.2.0],
+ [
+ AC_DEFINE(HAVE_LIBGCRYPT, 1, [Define if libgcrypt is available])
+ HAVE_HLS="yes"
+ ], [
+ HAVE_HLS="no"
+ ])
+ ])
])
else