summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Stoughton <nstoughton@aether.com>2014-12-09 08:38:55 -0800
committerArun Raghavan <git@arunraghavan.net>2014-12-11 09:08:47 +0530
commita344b99c987a393b7ee460cd6c4e7060bbe0f25c (patch)
tree1c63cb6734b220c6667b0f14480b2065a2afb3fa /configure.ac
parentc8fa688d26e2482419b1d785b0d4537d4235f267 (diff)
downloadgstreamer-plugins-bad-a344b99c987a393b7ee460cd6c4e7060bbe0f25c.tar.gz
bluez: support compile-time distinction between bluez4 and bluez5
Signed-off-by: Nick Stoughton <nstoughton@aether.com> https://bugzilla.gnome.org/show_bug.cgi?id=738626
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index bda83f826..ff75aea59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1655,11 +1655,20 @@ esac
dnl *** bluez ***
translit(dnm, m, l) AM_CONDITIONAL(USE_BLUEZ, true)
AG_GST_CHECK_FEATURE(BLUEZ, [Bluez], bluez, [
- PKG_CHECK_MODULES([BLUEZ], [bluez < 5.0], [
+ PKG_CHECK_MODULES([BLUEZ4], [bluez < 5.0], [
+ HAVE_BLUEZ=yes
+ AC_DEFINE(HAVE_BLUEZ4,[1],[Old bluez detected])
+ ], [
+ PKG_CHECK_MODULES([BLUEZ5], [bluez >= 5.0], [
+ HAVE_BLUEZ=yes
+ AC_DEFINE(HAVE_BLUEZ5,[1],[Current bluez detected])
+ ], [
+ HAVE_BLUEZ=no
+ ])
+ ])
+ AS_IF([ test x$HAVE_BLUEZ = xyes ],[
dnl FIXME: we should be able to replace this with the GLib DBus stuff
PKG_CHECK_MODULES([DBUS], [dbus-1], [HAVE_BLUEZ=yes], [HAVE_BLUEZ=no])
- ], [
- HAVE_BLUEZ=no
])
])