summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2015-03-16 17:33:03 +0100
committerSebastian Dröge <sebastian@centricular.com>2015-03-16 18:23:27 +0100
commit1e0ed9af11b70a6e743d9d394d2e22b12f569d58 (patch)
tree541b568425bec672ca0390f1d7007dce6be31a50 /configure.ac
parentd5ca311a0db7bffc63c2e579a196b626a257a750 (diff)
downloadgstreamer-plugins-bad-1e0ed9af11b70a6e743d9d394d2e22b12f569d58.tar.gz
dtls: Add new DTLS plugin
This is a copy of the Ericsson DTLS plugin from https://github.com/EricssonResearch/openwebrtc-gst-plugins/tree/master/ext/erdtls/src https://bugzilla.gnome.org/show_bug.cgi?id=744582
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4822af13b..f466a3eec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2137,6 +2137,18 @@ AG_GST_CHECK_FEATURE(SRTP, [srtp library], srtp, [
AC_SUBST(SRTP_CFLAGS)
])
+dnl *** dtls ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_DTLS, true)
+AG_GST_CHECK_FEATURE(DTLS, [DTLS plugin], dtls, [
+ PKG_CHECK_MODULES(DTLS, [ openssl >= 0.9.5 libcrypto ], [
+ HAVE_DTLS="yes"
+ AC_SUBST(DTLS_CFLAGS)
+ AC_SUBST(DTLS_LIBS)
+ ], [
+ HAVE_DTLS="no"
+ ])
+])
+
dnl *** linsys ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LINSYS, true)
AG_GST_CHECK_FEATURE(LINSYS, [Linear Systems SDI plugin], linsys, [
@@ -3014,6 +3026,7 @@ AM_CONDITIONAL(USE_UVCH264, false)
AM_CONDITIONAL(USE_WEBP, false)
AM_CONDITIONAL(USE_OPENH264, false)
AM_CONDITIONAL(USE_X265, false)
+AM_CONDITIONAL(USE_DTLS, false)
fi dnl of EXT plugins
@@ -3310,6 +3323,7 @@ ext/webp/Makefile
ext/x265/Makefile
ext/xvid/Makefile
ext/zbar/Makefile
+ext/dtls/Makefile
po/Makefile.in
docs/Makefile
docs/plugins/Makefile