summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheermerali@gmail.com>2015-01-13 11:32:03 -0800
committerZaheer Abbas Merali <zaheermerali@gmail.com>2015-01-13 11:32:03 -0800
commit3a4d988a293ba2cc39b8016fea50ba824829067c (patch)
treef88bbe687d7a5e29269d88b043377ae21523caad /configure.ac
parent21b7ce550474316a4905f30b9cff1135d66a3231 (diff)
downloadgstreamer-plugins-bad-3a4d988a293ba2cc39b8016fea50ba824829067c.tar.gz
Revert "Revert "openh264: fix to work with released versions and master of upstream""
This reverts commit 329f0ccba1aa604da1bd80293fd1fe717447df5d.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 1 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index fd1ad0321..71ca13c27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2521,27 +2521,7 @@ AG_GST_CHECK_FEATURE(OPENEXR, [openexr library], openexr, [
dnl *** openh264 ***
translit(dnm, m, l) AM_CONDITIONAL(USE_OPENH264, true)
AG_GST_CHECK_FEATURE(OPENH264, [openh264 library], openh264, [
- AC_LANG_PUSH([C++])
- AG_GST_CHECK_LIBHEADER(OPENH264, openh264, WelsSnprintf, $PTHREAD_LIBS,
- wels/codec_api.h, [
- AC_MSG_CHECKING([for right openh264 version/snapshot])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <wels/codec_app_def.h>
-#include <wels/codec_api.h>]], [[
- SFrameBSInfo frame_info;
- SEncParamExt enc_params;
- enc_params.iInputCsp = videoFormatI420;
- int *p = (int *) &frame_info.eFrameType;
- *p = RC_LOW_BW_MODE;
- ]])], [
- AC_MSG_RESULT(yes)
- OPENH264_LIBS="-lopenh264 $PTHREAD_LIBS"
- ], [
- AC_MSG_RESULT(no)
- HAVE_OPENH264="no"
- ])
- ])
- AC_LANG_POP([C++])
- AC_SUBST(OPENH264_LIBS)
+ AG_GST_PKG_CHECK_MODULES(OPENH264, openh264)
])
dnl *** OpenJPEG ***