summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2014-10-03 13:45:26 +0300
committerSebastian Dröge <sebastian@centricular.com>2014-10-03 17:23:35 +0300
commitcf4ec9b04e1ada5532e9ad0d8d14ad7f5ea01d5c (patch)
tree2e647bbaa6c67a6c910bfdf7e6f2b5fead64e204 /configure.ac
parent3637296ee92da455a08301fbb168cb69dacc9d58 (diff)
downloadgstreamer-plugins-bad-cf4ec9b04e1ada5532e9ad0d8d14ad7f5ea01d5c.tar.gz
openh264: Add OpenH264 based encoder/decoder elements
These are the openh264 elements released under the BSD-2 license by Ericsson as part of the OpenWebRTC project. https://github.com/EricssonResearch/openwebrtc-gst-plugins https://bugzilla.gnome.org/show_bug.cgi?id=737788
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e738f2986..56ede7d01 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2550,6 +2550,15 @@ AG_GST_CHECK_FEATURE(OPENEXR, [openexr library], openexr, [
AG_GST_PKG_CHECK_MODULES(OPENEXR, OpenEXR)
])
+dnl *** openh264 ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_OPENH264, true)
+AG_GST_CHECK_FEATURE(OPENH264, [openh264 library], openh264, [
+ HAVE_OPENH264="yes"
+ AG_GST_CHECK_LIBHEADER(OPENH264, openh264, WelsSnprintf, ,wels/codec_api.h,
+ OPENH264_LIBS="-lopenh264", HAVE_OPENH264="no")
+ AC_SUBST(OPENH264_LIBS)
+])
+
dnl *** OpenJPEG ***
translit(dnm, m, l) AM_CONDITIONAL(USE_OPENJPEG, true)
AG_GST_CHECK_FEATURE(OPENJPEG, [openjpeg library], openjpeg, [
@@ -3089,6 +3098,7 @@ AM_CONDITIONAL(USE_TELETEXTDEC, false)
AM_CONDITIONAL(USE_SNDIO, false)
AM_CONDITIONAL(USE_UVCH264, false)
AM_CONDITIONAL(USE_WEBP, false)
+AM_CONDITIONAL(USE_OPENH264, false)
fi dnl of EXT plugins
@@ -3358,6 +3368,7 @@ ext/ofa/Makefile
ext/openal/Makefile
ext/opencv/Makefile
ext/openexr/Makefile
+ext/openh264/Makefile
ext/openjpeg/Makefile
ext/openni2/Makefile
ext/opus/Makefile