summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <git@arunraghavan.net>2015-07-03 19:24:58 +0530
committerArun Raghavan <git@arunraghavan.net>2015-07-03 19:24:58 +0530
commit03190137268f38ca10f8ec242ea14102ee07967d (patch)
tree07ff7c2fc8b3f012c7595131e6b30e5246ca7204 /configure.ac
parent5ebde18f03ff126f0a11087f15a602dbc73f4b5e (diff)
downloadgstreamer-plugins-bad-03190137268f38ca10f8ec242ea14102ee07967d.tar.gz
build: Fix broken BlueZ configure check
The previous commit left an extra set of brackets, and missed removing the explicit dbus check (which is no longer needed since we're using gdbus).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 7 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 8a80569fc..672fb6c18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1615,21 +1615,16 @@ esac
dnl *** bluez ***
translit(dnm, m, l) AM_CONDITIONAL(USE_BLUEZ, true)
AG_GST_CHECK_FEATURE(BLUEZ, [Bluez], bluez, [
- PKG_CHECK_MODULES([BLUEZ5], [bluez >= 5.0], [
- PKG_CHECK_MODULES([GIO_UNIX], gio-unix-2.0 > 2.24, [
- AC_CHECK_PROG([GDBUS_CODEGEN],[gdbus-codegen],[gdbus-codegen])
- HAVE_BLUEZ=yes
- AC_DEFINE(HAVE_BLUEZ5,[1],[Bluez5 detected])
- ], [
- HAVE_BLUEZ=no
- ])
+ PKG_CHECK_MODULES([BLUEZ5], [bluez >= 5.0], [
+ PKG_CHECK_MODULES([GIO_UNIX], gio-unix-2.0 > 2.24, [
+ AC_CHECK_PROG([GDBUS_CODEGEN],[gdbus-codegen],[gdbus-codegen])
+ HAVE_BLUEZ=yes
+ AC_DEFINE(HAVE_BLUEZ5,[1],[Bluez5 detected])
], [
HAVE_BLUEZ=no
])
- ])
- AS_IF([ test x$HAVE_BLUEZ = xyes ],[
- dnl FIXME: we should be able to replace this with the GLib DBus stuff
- PKG_CHECK_MODULES([DBUS], [dbus-1], [HAVE_BLUEZ=yes], [HAVE_BLUEZ=no])
+ ], [
+ HAVE_BLUEZ=no
])
])