summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2014-10-22 12:36:36 +0100
committerTim-Philipp Müller <tim@centricular.com>2014-10-22 12:36:36 +0100
commit6c8446ffa6eb11d83d6df8908adf10ad65961493 (patch)
tree618a5727e82c8d7008d4c19822df32f5cc8027f5 /configure.ac
parentaf6e2228b2a3bb9eb91e367ff941e1d1746ff221 (diff)
downloadgstreamer-plugins-bad-6c8446ffa6eb11d83d6df8908adf10ad65961493.tar.gz
configure: simplify openh264 check
Of course PTHREADS_CFLAGS is not used anywhere now for the check, but that was the case before as well.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index bdabd858b..e915ea881 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2575,12 +2575,8 @@ AG_GST_CHECK_FEATURE(OPENEXR, [openexr library], openexr, [
dnl *** openh264 ***
translit(dnm, m, l) AM_CONDITIONAL(USE_OPENH264, true)
AG_GST_CHECK_FEATURE(OPENH264, [openh264 library], openh264, [
- HAVE_OPENH264="yes"
- saved_LIBS="$LIBS"
- LIBS="$PTHREAD_LIBS $LIBS"
- AG_GST_CHECK_LIBHEADER(OPENH264, openh264, WelsSnprintf, ,wels/codec_api.h,
- OPENH264_LIBS="-lopenh264 $PTHREAD_LIBS", HAVE_OPENH264="no")
- LIBS=$saved_LIBS
+ AG_GST_CHECK_LIBHEADER(OPENH264, openh264, WelsSnprintf, $PTHREAD_LIBS,
+ wels/codec_api.h, OPENH264_LIBS="-lopenh264 $PTHREAD_LIBS")
AC_SUBST(OPENH264_LIBS)
])