summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2016-01-15 16:07:27 +1100
committerMatthew Waters <matthew@centricular.com>2016-01-15 16:07:27 +1100
commit6b6b59137094ed398bbf478060f0da4957b6c6e3 (patch)
tree01359100b8aa5f13ea357ea739b7a14a1283087e /configure.ac
parent155f0acfab8bbe0e30258e4a8726ea2adb2b073c (diff)
downloadgstreamer-plugins-bad-6b6b59137094ed398bbf478060f0da4957b6c6e3.tar.gz
gl: add compatibility definition of GLint64
e.g. anrdoid doesn't have it
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index be4f82390..ac214128c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1340,6 +1340,7 @@ GST_GL_HAVE_GLSIZEIPTR=0
GST_GL_HAVE_GLINTPTR=0
GST_GL_HAVE_GLSYNC=0
GST_GL_HAVE_GLUINT64=0
+GST_GL_HAVE_GLINT64=0
old_CFLAGS=$CFLAGS
CFLAGS="$GL_CFLAGS $CFLAGS"
@@ -1374,6 +1375,11 @@ if test "x$ac_cv_type_GLuint64" = "xyes"; then
GST_GL_HAVE_GLUINT64=1
fi
+AC_CHECK_TYPES(GLint64, [], [], [[$GL_INCLUDES]])
+if test "x$ac_cv_type_GLint64" = "xyes"; then
+ GST_GL_HAVE_GLINT64=1
+fi
+
CFLAGS=$old_CFLAGS
GL_CONFIG_DEFINES="$GL_CONFIG_DEFINES
@@ -1383,6 +1389,7 @@ GL_CONFIG_DEFINES="$GL_CONFIG_DEFINES
#define GST_GL_HAVE_GLINTPTR $GST_GL_HAVE_GLINTPTR
#define GST_GL_HAVE_GLSYNC $GST_GL_HAVE_GLSYNC
#define GST_GL_HAVE_GLUINT64 $GST_GL_HAVE_GLUINT64
+#define GST_GL_HAVE_GLINT64 $GST_GL_HAVE_GLINT64
"
AC_CONFIG_COMMANDS([gst-libs/gst/gl/gstglconfig.h], [