summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2016-08-30 16:21:25 +0300
committerSebastian Dröge <sebastian@centricular.com>2016-09-01 13:02:18 +0300
commite6b538402764a29351ffeecdbf2407ed8e7398a1 (patch)
treee966f65b7b76fba3c6915916e23a64f5cf893116 /configure.ac
parent42f44f3fed2d86d45a47853847b466bccfacd619 (diff)
downloadgstreamer-plugins-bad-e6b538402764a29351ffeecdbf2407ed8e7398a1.tar.gz
applemedia: Conditionally compile qtkitvideosrc
The API was deprecated in 10.9 and apparently does not exist in the SDK for macOS Sierra anymore. https://bugzilla.gnome.org/show_bug.cgi?id=770587
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f0a1e1713..418268c35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -531,6 +531,7 @@ dnl *** plug-ins to exclude ***
AC_CHECK_HEADER(AVFoundation/AVFoundation.h, HAVE_AVFOUNDATION="yes", HAVE_AVFOUNDATION="no", [-])
AC_CHECK_HEADER(MobileCoreServices/MobileCoreServices.h, HAVE_IOS="yes", HAVE_IOS="no", [-])
AC_CHECK_HEADER(VideoToolbox/VideoToolbox.h, HAVE_VIDEOTOOLBOX="yes", HAVE_VIDEOTOOLBOX="no", [-])
+AC_CHECK_HEADER(QTKit/QTKit.h, HAVE_QTKIT="yes", HAVE_QTKIT="no", [-])
if test "x$HAVE_VIDEOTOOLBOX" = "xyes"; then
old_LIBS=$LIBS
@@ -557,6 +558,10 @@ if test "x$HAVE_VIDEOTOOLBOX" = "xyes"; then
AC_DEFINE(HAVE_VIDEOTOOLBOX, 1, [Define if building with VideoToolbox])
fi
+AM_CONDITIONAL(HAVE_QTKIT, test "x$HAVE_QTKIT" = "xyes")
+if test "x$HAVE_QTKIT" = "xyes"; then
+ AC_DEFINE(HAVE_QTKIT, 1, [Define if building with QTKit])
+fi
dnl disable gst plugins we might not be able to build on this
dnl platform: (ugly but minimally invasive)
dnl FIXME: maybe move to sys, or make work with winsock2