summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThiago Santos <thiagoss@osg.samsung.com>2015-07-21 18:02:38 -0300
committerThiago Santos <thiagoss@osg.samsung.com>2016-02-16 12:23:45 -0300
commitb5a4de197a24016e6893b5428e893887b9443454 (patch)
treeec00dbce92e1eb1e604a0dc21764cb97e66c8cea /configure.ac
parent0b7276d01a235c1af3c1e0df51e12612c1f965ba (diff)
downloadgstreamer-plugins-bad-b5a4de197a24016e6893b5428e893887b9443454.tar.gz
configure: improve check for wayland-scanner binary
The plugin doesn't need the wayland-scanner package to be built or run, it only needs the wayland-scanner program during compile time. When cross-compiling, build systems might not have the wayland-scanner package for the target system as it is a developer's tool, while it should still be possible to use wayland-scanner from the host system. This patch fixes it by not requiring the wayland-scanner package but just the binary itself. Note that the check is done outside of the PKG_CHECK_MODULES as it doesn't work inside of it. https://bugzilla.gnome.org/show_bug.cgi?id=752688
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c50647cca..d167bd568 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2150,14 +2150,20 @@ AG_GST_CHECK_FEATURE(DIRECTFB, [directfb], dfbvideosink , [
dnl **** Wayland ****
translit(dnm, m, l) AM_CONDITIONAL(USE_WAYLAND, true)
+AC_PATH_PROG([wayland_scanner], [wayland-scanner])
AG_GST_CHECK_FEATURE(WAYLAND, [wayland sink], wayland , [
- PKG_CHECK_MODULES(WAYLAND, wayland-client >= 1.4.0 wayland-scanner, [
- HAVE_WAYLAND="yes" ], [ HAVE_WAYLAND="no"
+ PKG_CHECK_MODULES(WAYLAND, wayland-client >= 1.4.0, [
+ if test "x$wayland_scanner" != "x"; then
+ HAVE_WAYLAND="yes"
+ else
+ AC_MSG_RESULT([wayland-scanner is required to build the wayland plugin])
+ HAVE_WAYLAND="no"
+ fi
+ ],
+ [ HAVE_WAYLAND="no"
])
])
-AC_PATH_PROG([wayland_scanner], [wayland-scanner])
-
dnl **** WebP ****
translit(dnm, m, l) AM_CONDITIONAL(USE_WEBP, true)
AG_GST_CHECK_FEATURE(WEBP, [WebP], webp , [