summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2015-12-23 09:55:26 +0100
committerSebastian Dröge <sebastian@centricular.com>2015-12-23 12:19:33 +0100
commit2f86923cbd41e2264d471a8893f93fb74939d249 (patch)
tree35fb2510559dea2a614c49d45f21ff857855a352 /configure.ac
parentd16eb47cca45034cb6f89cd62712233be060b4e2 (diff)
downloadgstreamer-plugins-bad-2f86923cbd41e2264d471a8893f93fb74939d249.tar.gz
player: Add unit test that is disabled by default
The unit test is downloading a few small media files from the Internet, which are then used during the test. "make clean" removes the files again.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0a29ec60b..3b104a45b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -396,6 +396,17 @@ fi
AC_SUBST(GST_PLUGIN_LIBTOOLFLAGS)
AM_CONDITIONAL(GST_PLUGIN_BUILD_STATIC, test "x$enable_static_plugins" = "xyes")
+AC_ARG_WITH([player-tests],
+ AS_HELP_STRING([--with-player-tests],[Enable GstPlayer tests that need network access (default: no)]))
+if test x$with_player_tests = xyes; then
+ AC_PATH_PROG([WGET], [wget], no)
+ if test x$WGET = xno; then
+ AC_MSG_WARN([wget required for GstPlayer tests but not found - disabling])
+ with_player_tests=no
+ fi
+fi
+AM_CONDITIONAL(WITH_GST_PLAYER_TESTS, test "x$with_player_tests" = "xyes")
+
# set by AG_GST_PARSE_SUBSYSTEM_DISABLES above
dnl make sure it doesn't complain about unused variables if debugging is disabled
NO_WARNINGS=""