summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2015-12-14 16:48:45 -0500
committerNicolas Dufresne <nicolas.dufresne@collabora.co.uk>2015-12-15 09:54:07 -0500
commit8265aca7d961aba37c9ff64498816f57f58e5de6 (patch)
tree1fde5490ff542397c717335aca9f791081f16cc9 /configure.ac
parentef53eabee3f5323be3b0dcf11d3672752900ef0e (diff)
downloadgstreamer-plugins-bad-8265aca7d961aba37c9ff64498816f57f58e5de6.tar.gz
opengl: Use pkg-config if available
libMesa ships .pc files now for gl/egl/glesv2. This patch makes use of it while keeping support for system without. https://bugzilla.gnome.org/show_bug.cgi?id=751068
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 184e9b2f6..f2d3c2483 100644
--- a/configure.ac
+++ b/configure.ac
@@ -671,13 +671,22 @@ case $host in
;;
*)
if test "x$NEED_GL" != "xno"; then
- AG_GST_CHECK_LIBHEADER(GL, GL, glTexImage2D,, GL/gl.h)
+ AG_GST_PKG_CHECK_MODULES(GL, gl)
+ if test "x$HAVE_GL" != "xyes"; then
+ AG_GST_CHECK_LIBHEADER(GL, GL, glTexImage2D,, GL/gl.h)
+ fi
fi
if test "x$NEED_GLES2" != "xno"; then
- AG_GST_CHECK_LIBHEADER(GLES2, GLESv2, glTexImage2D,, GLES2/gl2.h)
+ AG_GST_PKG_CHECK_MODULES(GLES2, glesv2)
+ if test "x$HAVE_GLES2" != "xyes"; then
+ AG_GST_CHECK_LIBHEADER(GLES2, GLESv2, glTexImage2D,, GLES2/gl2.h)
+ fi
fi
if test "x$NEED_EGL" != "xno"; then
- AG_GST_CHECK_LIBHEADER(EGL, EGL, eglGetError,, EGL/egl.h)
+ AG_GST_PKG_CHECK_MODULES(EGL, egl)
+ if test "x$HAVE_EGL" != "xyes"; then
+ AG_GST_CHECK_LIBHEADER(EGL, EGL, eglGetError,, EGL/egl.h)
+ fi
fi
old_LIBS=$LIBS