summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2016-02-10 20:43:47 +0100
committerVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2016-04-11 19:57:48 +0200
commitc419d17dbfecaf9f51663df312d9fa04537eacc4 (patch)
treec57f9e740b43aa004cbbc973d4ac91c99eb6eeab /configure.ac
parent1aee6cdc25572d856ca414940689194f54fd9054 (diff)
downloadgstreamer-plugins-bad-c419d17dbfecaf9f51663df312d9fa04537eacc4.tar.gz
kmssink: add dmabuf support
This patch will enable the import of dmabufs into a KMS buffer using the PRIME kernel interface. If the driver does not support prime import, the method is skipped. It has been tested with a Freescale I.MX6 board. https://bugzilla.gnome.org/show_bug.cgi?id=761059
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 841064540..a63e983e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2326,6 +2326,7 @@ dnl *** kms ***
translit(dnm, m, l) AM_CONDITIONAL(USE_KMS, true)
AG_GST_CHECK_FEATURE(KMS, [drm/kms libraries], kms, [
AG_GST_PKG_CHECK_MODULES(GST_VIDEO, gstreamer-video-1.0)
+ AG_GST_PKG_CHECK_MODULES(GST_ALLOCATORS, gstreamer-allocators-1.0)
PKG_CHECK_MODULES([DRM], [libdrm libkms], HAVE_KMS=yes, HAVE_KMS=no)
])