summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Waters <matthew@centricular.com>2016-07-08 19:03:06 +1000
committerMatthew Waters <matthew@centricular.com>2016-07-11 11:29:07 +1000
commit2ae16c2f685ab81916526a65969d821c4fa3322e (patch)
tree1bfd779ee4a670e8783ed1fcf36cb5d29f006b8e /configure.ac
parent8330f7aa26b5c53c49baa0d9859252ee862488a4 (diff)
downloadgstreamer-plugins-bad-2ae16c2f685ab81916526a65969d821c4fa3322e.tar.gz
gl/build: fix configure when --enable-cocoa is passed on OS X
https://bugzilla.gnome.org/show_bug.cgi?id=768553
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 573d3bdfb..4ca9aaa44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -789,6 +789,17 @@ case $host in
CFLAGS=$old_CFLAGS
PKG_CHECK_MODULES(WAYLAND_EGL, wayland-client >= 1.0 wayland-cursor >= 1.0 wayland-egl >= 9.0, HAVE_WAYLAND_EGL=yes, HAVE_WAYLAND_EGL=no)
+
+ # OS X and iOS always have GL available
+ case $host in
+ *-darwin*)
+ if test "x$HAVE_IOS" = "xyes"; then
+ HAVE_GLES2=yes
+ else
+ HAVE_GL=yes
+ fi
+ ;;
+ esac
;;
esac