summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2010-03-22 13:16:33 +0100
committerBenjamin Otte <otte@redhat.com>2010-03-22 13:16:33 +0100
commit33c2f5fb01b1cb9145751a745cfa2514421fa7b3 (patch)
treef8c0318f6d50928ee96ed1e8663a0c0c5fce7d3e /configure.ac
parent010789159d7bf274e11f0b4bec5c66543ad1220f (diff)
downloadgstreamer-plugins-bad-33c2f5fb01b1cb9145751a745cfa2514421fa7b3.tar.gz
Add -Wwrite-strings
and fix its warnings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a79c17874..6a9fb04ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -240,11 +240,13 @@ AG_GST_SET_PLUGINDIR
dnl define an ERROR_CFLAGS Makefile variable
AG_GST_SET_ERROR_CFLAGS($GST_GIT, [
- -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wundef ])
+ -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wundef
+ -Wwrite-strings ])
dnl define an ERROR_CXXFLAGS Makefile variable
AG_GST_SET_ERROR_CXXFLAGS($GST_GIT, [
- -Wmissing-declarations -Wredundant-decls -Wundef ])
+ -Wmissing-declarations -Wredundant-decls -Wundef
+ -Wwrite-strings ])
dnl define correct level for debugging messages
AG_GST_SET_LEVEL_DEFAULT($GST_GIT)