summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2016-06-14 16:34:35 -0700
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2016-09-15 12:10:59 -0400
commita5ead086f9b3cfaa3f286cec31fc4fcd1bc1970d (patch)
treec5a6e74e8e7020e308e1a7b8e2f174d2c23a4a89 /configure.ac
parent68cbf7802dc6dbf85a9596b3265e5f285dbf9bd6 (diff)
downloadgstreamer-plugins-bad-a5ead086f9b3cfaa3f286cec31fc4fcd1bc1970d.tar.gz
wayland: Update from scaler to viewporter protocol
Signed-off-by: Scott D Phillips <scott.d.phillips@intel.com> https://bugzilla.gnome.org/show_bug.cgi?id=767671
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 11 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index d6c2adf5d..0b97fcbc4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2219,13 +2219,17 @@ translit(dnm, m, l) AM_CONDITIONAL(USE_WAYLAND, true)
AC_PATH_PROG([wayland_scanner], [wayland-scanner])
AG_GST_CHECK_FEATURE(WAYLAND, [wayland sink], wayland , [
PKG_CHECK_MODULES(WAYLAND, wayland-client >= 1.4.0, [
- if test "x$wayland_scanner" != "x"; then
- HAVE_WAYLAND="yes"
- else
- AC_MSG_RESULT([wayland-scanner is required to build the wayland plugin])
- HAVE_WAYLAND="no"
- fi
- ],
+ PKG_CHECK_MODULES(WAYLAND_PROTOCOLS, wayland-protocols >= 1.4, [
+ if test "x$wayland_scanner" != "x"; then
+ HAVE_WAYLAND="yes"
+ AC_SUBST(WAYLAND_PROTOCOLS_DATADIR, `$PKG_CONFIG --variable=pkgdatadir wayland-protocols`)
+ else
+ AC_MSG_RESULT([wayland-scanner is required to build the wayland plugin])
+ HAVE_WAYLAND="no"
+ fi
+ ],
+ [ HAVE_WAYLAND="no"
+ ])],
[ HAVE_WAYLAND="no"
])
])