summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuis de Bethencourt <luis@debethencourt.com>2015-08-17 17:38:15 +0100
committerLuis de Bethencourt <luis@debethencourt.com>2015-08-17 18:05:50 +0100
commit07ee52db5dbddf35ab22199a1960e9f5cc8aae73 (patch)
tree8b2a6d4e511dfbfa45849dac5656906c31132657 /configure.ac
parentdce7ffb04efb30762b7282436ab91eb4a8ea6250 (diff)
downloadgstreamer-plugins-bad-07ee52db5dbddf35ab22199a1960e9f5cc8aae73.tar.gz
opencv: support alternative path convention
Some distributions store OpenCV files in /usr/share/opencv and some others (and default when building from source) install them in /usr/share/OpenCV. Support both to find cascade files. https://bugzilla.gnome.org/show_bug.cgi?id=753651
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 10d39373d..cc076de69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2487,6 +2487,9 @@ AG_GST_CHECK_FEATURE(OPENCV, [opencv plugins], opencv, [
AC_SUBST(OPENCV_PREFIX)
AC_SUBST(OPENCV_CFLAGS)
AC_SUBST(OPENCV_LIBS)
+ AC_CHECK_FILE([$OPENCV_PREFIX/share/opencv/],
+ [AC_DEFINE_UNQUOTED(OPENCV_PATH_NAME, ["opencv"], [OpenCV path name])],
+ [AC_DEFINE_UNQUOTED(OPENCV_PATH_NAME, ["OpenCV"], [OpenCV path name])])
])
dnl *** OpenEXR ***