summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Toso <victortoso@redhat.com>2015-03-31 10:53:55 +0100
committerJulien Isorce <j.isorce@samsung.com>2015-03-31 10:53:55 +0100
commit1b564bfb8b0db43a24cf311dca24038558b80a68 (patch)
treef76fc449d14f3879f979f7070ed9d86d932fe728 /configure.ac
parent4504356ddab34a680d0d19f5d4c130114f621ea3 (diff)
downloadgstreamer-plugins-bad-1b564bfb8b0db43a24cf311dca24038558b80a68.tar.gz
directsoundsrc: Implement volume and mute
Using the MixerAPI as IDirectSoundCaptureBuffer doesn't implement volume control. https://bugzilla.gnome.org/show_bug.cgi?id=744383
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f466a3eec..ae513734b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1397,12 +1397,13 @@ AG_GST_CHECK_FEATURE(DIRECTSOUND, [DirectSound], directsoundsrc, [
save_LIBS="$LIBS"
CFLAGS="$CFLAGS $DIRECTX_CFLAGS"
LDFLAGS="$LDFLAGS $DIRECTX_LDFLAGS"
- LIBS="$LIBS -ldsound -ldxerr9 -luser32"
+ LIBS="$LIBS -lwinmm -ldsound -ldxerr9 -luser32"
AC_MSG_CHECKING(for DirectSound LDFLAGS)
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
#include <windows.h>
#include <dxerr9.h>
#include <dsound.h>
+#include <mmsystem.h>
]], [[
DXGetErrorString9 (0);
DirectSoundCreate(NULL, NULL, NULL);
@@ -1416,7 +1417,7 @@ AG_GST_CHECK_FEATURE(DIRECTSOUND, [DirectSound], directsoundsrc, [
if test "x$HAVE_DIRECTSOUND" = "xyes"; then
dnl this is much more than we want
- DIRECTSOUND_LIBS="-ldsound -ldxerr9 -luser32"
+ DIRECTSOUND_LIBS="-lwinmm -ldsound -ldxerr9 -luser32"
AC_SUBST(DIRECTX_CFLAGS)
AC_SUBST(DIRECTX_LDFLAGS)
AC_SUBST(DIRECTSOUND_LIBS)